Java 8 Support & Improved Server Updates

Hello all!

We’ve finally finished, tested, and pushed out some big changes to our backend systems allowing us to support Java 7 and Java 8 simultaneously, as well as a lot of improvements to the server startup and modpack installation/update processes.

Java 8 Support

This is one of the most exciting upgrades to our system recently. Your server will now automatically select Java 7 or 8 based on the type of server you’re using. Vanilla Minecraft, Spigot, CraftBukkit, and BungeeCord will automatically use Java 8. Other server types such as Forge and Cauldron, as well as FTB, ATLauncher, and Technic modpacks, will use Java 7. You can override this setting by editing the .java_version file via FTP, then restarting your server.

There are three settings you can choose from: “auto”, 7, and 8. The auto setting will pick the best version for your server automatically. The other two are fairly self-explanatory. Please note that many modpacks are not compatible with Java 8, so changing this setting can cause your server to stop working. If that happens, you can simply delete the .java_version file or switch it back to “auto”, then restart your server.

Server and Modpack Installation / Updates

We’re working to streamline this process in preparation for our new control panel. In the meantime, this means faster and more efficient modpack installations and updates. That also includes server types that aren’t modpacks as well, including vanilla Minecraft, BungeeCord, etc.

As usual, you can enable automatic updates under Files -> Config Files -> Automatic Updates in Multicraft. Once enabled, each time you restart your server, it will check for an update.


We’re hoping to share some screenshots of the new control panel soon, so check back often!

– The CubedHost Team